
 Java OpenStreetMap Editor 
Basic Manual

After  this  manual  the  participants  should  be  well  versed  in  basic  editing  techniques  using  Java 
OpenStreetMap Editor (JOSM). 

 1 Introduction

 1.1 What is Java OpenStreetMap Editor (JOSM)?

Java OpenStreetMap Editor is a desktop editing aplication, written in Java. It runs on Windows, Mac 
OS and Linux. It supports loading stand alone GPX tracks and GPX track data from the OSM database 
as well as loading and editing existing nodes, ways, metadata tags and relations from the OSM 
database.  

 1.2 What is JAVA?

Java technology is an object-oriented, platform-independent, multithreaded programming environment. 

In other words, it's a programming language which uses “objects” – data structures consisting of data 
fields and methods together with their interactions – to design applications and computer programs.

JAVA is a platform-independent programming language as it works on the principle “compile once, run 
everywhere”. Code written and compiled in JAVA can be executed on any platform.

Multithreaded programming model allows multiple threads to exist within the context of a single 
process. A thread of execution in computer science is the smallest unit of processing that can be 
scheduled by an operation system.    
  

 2 Installing

 2.1 Installing JAVA

Download Java from http://www.java.com/en/download/help/download_options.xml

The procedure to download Java broadly consists of:
➢ Download and Install
➢ Enable and Configure
➢ Test installation

The software installed:
➢ The Java Download which includes 

http://www.java.com/en/download/help/download_options.xml


 Java Plug-in software and 
 Java Virtual Machine

➢ The Java Web Start software

 2.2 Installing JOSM

Download the latest JOSM version (josm-tested.jar) from http://josm.openstreetmap.de/ or 
http://wiki.openstreetmap.org/wiki/JOSM

There area generally two versions of JOSM available:
➢ tested and
➢ latest

The tested version of JOSM is more stable while the latest is more up-to-date but can contain bugs. 
There are fairly regular updates to JOSM, so always try running a recent version (and also recent 
plugins).

JOSM version is distributable as executable JAR file which can usually be run just by double clicking 
if Java is correctly installed. You are ready to go!

 3 JOSM user interface 

Run JOSM by double clicking the JAR file. Once JOSM is successfully launched the main window 
appears. At startup the window shows the Massage of the Day, downloaded from the JOSM website. 

JOSM Message of the day: 

JOSM welcome page

http://wiki.openstreetmap.org/wiki/JOSM
http://josm.openstreetmap.de/


Interface is a bit bare until some data is loaded.
 
JOSM Interface: 

 

Map View – The main window where the geodata is displayed and editing takes place.

Main Menu – The menu is customizable depending on which plugins you have installed.

Shortcur Toolbar – The buttons in this toolbar are shortcuts to commands from the Main Menu. This 
toolbar is highly customizable, with the ability to add and remove menus items from the preference 
dialog.

Edit Tools – Contains drawing tools and the show/hide buttons for the Toggle Dialogs window. 

Information Panels – These show information about the data in JOSM, including a list of selected 
objects, how the elected objects are tagged, who the last mapper to edit a feature was, and the different 
layers in the view.  

Status Bar – Gives coordinates and measurements for features, as well as a hint of the current tools 
function.

JOSM interface
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 4 Getting started with JOSM

 4.1 Starting JOSM

Start JOSM by double-clicking the executable JAR file. Once JOSM is successfully launched the main 
window showing the Message of the Day appears.

 4.2 Zooming, scale bar and panning

Within the main editing area (Map View) you can pan around and zoom in and out.

➢ Zoom using the mouse scroll-wheel. Alternatively use the zoom bar at the top-left or press 
Crtl+',' and Crtl-'.'  While zooming in point the mouse to the data you wish to zoom towards. If 
you can't see anything you probably need to zoom out (scroll backwards).

Zoom Bar

➢ Or Zoom by selecting the magnifier from the Edit Tools, then select the area you want to zoom 
in by drawing a bounding box in the Map View. The “View Menu” offers convenient zoom 
functions to pan the Map View automatically. 

➢ To Pan around drag the right mouse button

 4.3 Load a local GPX file

Loading data into JOSM:
 

➢ Press File > Open… or File Open icon  or press Crtl + O 
➢ Locate the file or multiple files on you computer and choose it/them
➢ Press Open

Selected file should appear in the Map View Window.



 5 Basic editing in JOSM

 5.1 Download data from OSM
 
To download map data from the OSM server:

➢ Press File > Download from OSM... or the icon on the Main Toolbar or press Crtl+Shift+D

The download dialog box appears:

Slippy map
Initially the 'slippy map' tab is selected. Slippy map provides a movable map like on the OSM front 
page with which you can interactively select the area to download. Move or “Slip” around the map by 
dragging the right mouse button. Zoom by using the mouse scroll-wheel or by double-clicking.

Check the check boxes at the top:

• “OpenStreetMap” – checked,
• “Raw GPS Data” – unchecked 
• “Download as new layer” – unchecked.  

Download data:

Download dialog box



➢ Use the left mouse button to drag a box around the area you want to download (this is the 
bounding box that will be downloaded) > press Download 

➢ Data should appear in the main Map View Window

You should download the area encompassing the area you will be editing but avoid downloading too 
much map data. You can always download more data as you need it. “Cross hatching” will be shown 
outside the area that you downloaded to remind you that you should not edit outside the area that you 
download from the server. The items outside the bounding box are included because they are included 
inside the bounding box.  

There are other ways to specify the area you want to download:

Bookmarks
You can select from your predefined bookmarks or create a new bookmark from your current bounding 
box or an area defined in another tab respectively.

Bounding Box
Select an area by entering the latitudes and longitudes directly or by extracting them from an 
openstreetmap.org URL.

Download data by pasting from the map on the OpenStreetMap site:

➢ Zoom into the area you are interested in
➢ Move the mouse over the “view” tab and copy the resulting URL or copy the Permalink given 

at the bottom right corner

Downloaded area in JOSM



➢ Copy the URL 
➢ Paste the URL into JOSM, into the “URL from openstreetmap.org” box 

Copy the URL into the Download Bounding Box tab:

Copy URL into Bounding Box

Areas around places
Search for specific places, street names, etc, in the OSM database. 

URL from openstreetmap.org



Tile Numbers
Enter number of tiles and a zoom level to download data of those tiles.   

 5.2 Basic operations: Select, Add, Delete

There are three main modes of operation when editing:

 (S)elect – for selecting elements, viewing/editing their tags and moving them.

 (A)dd – for adding elements, such as standalone nodes, adding new nodes to create a new way, 
extend an existing way.

 (D)elete – for deleting elements.

 5.3 Drawing basic elements

OpenStreetMap data is made up of the following elements or data primitives:

Nodes: The dots that are used to mark specific locations or for drawing the segments between these 
locations. Nodes are points in space. Each node has its latitude and longitude. 

Ways: An ordered list of nodes, displayed as connected by line segments. They are used to describe 
roads, paths etc. A special way is a so called Closed Way or Area: Closed ways are ways which go in a 
complete loop. They are used to describe areas like parks, lakes, islands or buildings. 

Relations: When different ways are linked to each other, but do not represent the same physical thing, 
a relation is used to describe the role of each way.  

 5.3.1 Drawing a node

To draw a standalone node:

➢ Clear your current selection by pressing Edit > Unselect All or press Escape button on your 
computer

➢ Press 'A' or select the Draw Nodes to begin drawing a node
➢ Press the Left Mouse Button somewhere in the Map View Window and press Escape or 

Node, way and enclosed way



Double Click to create a node
➢ Go back to Select mode 

A node

 5.3.2 Drawing a Way

When drawing a way you need to think what is currently selected. 

➢ Clear your current selection by pressing Edit > Unselect All or press Escape button on your 
computer

➢ Press 'A' or select the Draw Nodes to begin drawing a brand new way
➢ Press the Left Mouse Button somewhere in the Map View Window to create a new node
➢ Press again somewhere and another node will appear, joined by the first segment of a way
➢ Keep pressing to draw a way with several nodes and segments on it
➢ To stop go back to Select mode or press 'S' or Escape button on your computer   

A way

 5.3.3 Drawing an Area (Closed way)

Area or closed way is a way in which the first and the last node are identical; enclosing an area. 

Draw an Area/Closed way:

➢ Clear your current selection by pressing Edit > Unselect All or press Escape button on your 
computer

➢ With nothing selected, press 'A' or select the Draw Nodes to begin adding a brand new way
➢ Press the left mouse button somewhere in the Map View Window to create a new node
➢ Press again somewhere and another node will appear, joined by the first segment of a way
➢ Keep pressing to draw an area
➢ At the end press on the first/start node of the way to create an area or a closed way
➢ Go back to Select mode



An area (Closed Way)

 5.4 Tagging

 5.4.1 What are Tags?

Tags are the fundamental method of describing geographic data in OpenStreetMap. In other 
words, tags are attributes (or descriptions) you attach to basic elements (nodes, ways, closed ways/areas 
and relations). 

A Tag is a Key = Value pair. As said they can be attached to nodes, ways, closed ways/areas and 
relations. In principle there are no content restrictions on tags that can be assigned to OSM elements, 
meaning any tags can be used as long as the values are verifiable. However many general interest 
features already have tagging recommendations which are listed on 
http://wiki.openstreetmap.org/wiki/Map_Features. It is recommended to use the tagging given there.  

Key is a string describing the general classification of the feature. The Value gives more specific 
information within the class Key.
Keys and generic Values are lower case and do not including space, use underscore instead.

In JOSM tags are displayed on the right side under “properties/memberships”. Selecting an element 
displays the table with key and value fields.

 5.4.2 What are Presets?

A preset is a predefined combination of tags (sometimes a single tag) that is given a “human-readable” 
name.

The presets menu contain a list of presets organized in thematic groups. Presets allow the user to tag 
objects by selecting them from the predefined menu. JOSM installation comes with a default set of 
these presets.   

Find presets:

➢ In JOSM go to Main Menu and press Presets

http://wiki.openstreetmap.org/wiki/Map_Features


When applying a preset to an element of the map, a dialog window may appear allowing the user to 
enter more precise and/or specific data. For example, the preset “Sports/Sport facilities/Stadium” will 
apply the tag leisure = stadium and will ask the user to enter the value for the optional keys name and 
sport. A list of common sports is suggested.

Applying the preset "Stadium" to a node

If a tag is included in a preset, an additional line will be displayed in the “Properties/Membership” 
panel, above the list of tags as shown below. Clicking on this line will open the preset dialog box 
shown above.

Preset properties

The users can create, add, modify and use their own presets, for example in specialized use cases like 
event mapping etc. (more on this in Advanced Editing).

 Presets in JOSM



 5.4.3 Add a tag

Add a new tag by using an Add A Tag button:

➢ Press the button Add a Tag 

Change values window appears where you can select a key or a value from the drop-down list. The 
drop-down list contains all the values in the downloaded area and all the know tags or presets.

Add a tag by using predefined Presets:

➢ Select a tag from Presets by pressing Presets tab on the Main Menu
➢ Select a tag from the drop-down
➢ Select the attributes 
➢ Press Apply Preset 

 5.4.4 Managing presets in JOSM

To search for a preset:

➢ Go to Presets > Search preset 

Set a preset as a part of the Main Toolbar (shortcut):

➢ Go to Edit > Preferences...
➢ Select Toolbar customization on the left side on the Preference dialogue box
➢ Set the Presets on the Main Toolbar 

Create your own presets:

 5.5 Relations

 Relations are used to group objects (ways/nodes) that are geographically related (connected or 
adjacent to one another). 

Add a tag



 5.6 Using panels

 

Panels appear on the right side of the of the JOSM interface inside the Toggle Menu. Show and hide 
panels by choosing them on the Edit Toolbar on the left side of the Main View window in JOSM. 

 5.7 Adding and adjusting nodes on a way

A way or an enclosed way can be modified by adding and adjusting nodes. 

To add a node: 

➢ Go to Add(A) mode and press somewhere on the segment 

Add a node
➢ Go to Select(S) mode, select and drag one of the crosses on a segment between two nodes   

Add a node by dragging the cross between the segments

To move a single node or a node of a way:

➢ Select the node and still in Select(S) drag the node around



 5.8 Splitting, unglueing, untangling and combining ways

 Split Way – splits ways into smaller ways. 

To split a way:

➢ Select a node where the split should occur
➢ Select Tools > Split Way 

The resulting ways will have the same tags which can now be changed for each separate way.

Before and after the split

CAUSION:
If the node lies in the middle of several ways you need to select the node (where the split should occur) 
and the way which is meant to be split!

 Combine Way – combines ways together to form one.

To combine a way:

➢ The ways need to be in-lined
➢ Select both ways at the same time by holding down the Shift 
➢ Press Tools > Combine Way 

If ways have different tags the combined way will share both tags (this can be changed).  



Before and after the combining the way

CAUSION:
Tags apply along the entire length of the way!

  
 UnGlue Ways – if two (or more) ways are connected at one node, this command will create a 

second node, freeing one way from the other. The action can also be used on a way to unglue it from 
any node it shares along its length.  

To unglue a way:

➢ The ways need to be glued together (sticking together at a node(s))
➢ Select a node where the unglueing should occur
➢ Select Tools > UnGlue Ways 

 

Before and after the unglueing



 5.9 Plugins

Plugins add extra functions to JOSM thus making it easier to use certain functions.  

 5.9.1 Managing plugins in JOSM

Plugins can be accessed through:

➢ Press Edit > Preferences... form the Main Menu 
➢ Select Plugins tab on the left of the Preferences window 
➢ Press Download list to do download the list of available plugins
➢ Tick the check box of the plugin you want to install and press Update plugins
➢ Restart JOSM 

Plugins dialogue box

 5.10 Using imagery

A number of satellite imagery providers provide imagery to OpenStreetMap. Imagery can be accessed 
through a built in plugin, called Imagery.



 5.10.1 Activate Imagery Providers

Activate Imagery providers, and select the imagery to be displayed:

➢ Go to Edit > Preferences
➢ Select Imagery Preferences tab on the left of the Preferences window
➢ Select Imagery Providers tab and select the imagery you want to be displayed
➢ Press Activate button and press OK

 5.10.2 Drawing nodes, ways and areas over imagery 

Drawing a node:

➢ Zoom-in to the object you want to draw but make sure you don't lose the resolution
➢ Go to Add(A) mode
➢ Draw a node in the middle of the object 
➢ Go back to Select mode 

Drawing a Point over satellite imagery

Drawing a way:

➢ Zoom-in to the object you want to draw but make sure you don't lose the resolution
➢ Go to Add(A) mode
➢ Draw a way in the middle of the object (road, railway etc.) by adding as many nodes and 

segments as necessary
➢ Go back to Select mode 



Drawing a line over satellite imagery

Drawing a closed way/area:

➢ Zoom-in to the object you want to draw but make sure you don't lose the resolution
➢ Go to Add(A) mode
➢ Draw a way (an enclosed way) around the edges of the object 
➢ Go back to Select mode

Drawing an area over satellite imagery

 5.11 Upload GPX to OSM

Once you've completed the the drawing over the traces in JOSM, you can  upload a GPX file 
containing a GPS trace to the OpenStreetMap site:

➢ Go to the main OSM page
➢ Login
➢ Press GPS traces on the top of the page



➢ Press Upload a trace
➢ Find and select the information you wish to upload
➢ Name the file
➢ Add tags which can be helpful to find a trace
➢ If you would like for your data to be available to others tick the Public box
➢ Upload

 5.12 Upload data to OSM

Once you are happy with your edits it's time to upload the changes to the OpenStreetMap server. 

Upload changes:

➢ Press File > Upload data or just press the icon
➢ On the Upload data window you can see all the changes/edits that were made
➢ Enter a brief description of the edits 
➢ Press Upload data
➢ If uploading for the first time enter a Username and Password as registered on the main 

OpenStreetMap.org website

Uploading your changes to OpenStreetMap

Enter Credentials window appears if you're edditing for the first time:



Enter Credentials window

The uploaded changes will appear on the map after a delay.

IMPORTANT!
When you upload to OpenStreetMap you agree to release your data contributions under the 
OpenStreetMap Lycense. Only contribute data which you are allowed to release (NO COPYING)!


